Tip

  1. Need help? Please let us know in the UMEP Community.
  2. Find an issue within this page? Please report it in the GitHub issues.
  3. A good understanding of SUEWS is a prerequisite to the proper use of SuPy.

FAQ

I cannot install SuPy following the docs, what is wrong there?

please check if your environment meets the following requirements:

  1. Operating system (OS):
  1. is it 64 bit? only 64 bit systems are supported.
  2. is your OS up to date? only recent desktop systems are supported:
  • Windows 10 and above
  • macOS 10.13 and above
  • Linux: no restriction; If SuPy cannot run on your specific Linux distribution, please report it to us.

You can get the OS information with the following code:

import platform
platform.platform()
  1. Python interpreter:
  1. is your Python interpreter 64 bit?

Check running mode with the following code:

import struct
struct.calcsize('P')*8
  1. is your Python version above 3.5?

Check version info with the following code:

import sys
sys.version

If your environment doesn’t meet the requirement by SuPy, please use a proper environment; otherwise, `please report your issue`__.

How do I know which version of SuPy I am using?

Use the following code:

import supy
supy.show_version()

Note

show_version is only available after v2019.5.28.

A kernel may have died exception happened, where did I go wrong?

The issue is highly likely due to invalid input to SuPy and SUEWS kernel. We are trying to avoid such exceptions, but unfortunately they might happen in some edge cases.

Please `report such issues to us`__ with your input files for debugging. Thanks!

How can I upgrade SuPy to an up-to-date version?

Run the following code in your terminal:

python3 -m pip install supy --upgrade